Recruitment App Login Issues

Incident Report for Venn Digital Ltd

Resolved

The login issue affecting some tenants has now been resolved.

The fix has been successfully deployed, and access to the recruitment application has been fully restored. All systems are operating as expected.

Thank you for your patience while we worked to resolve this issue.
Posted Feb 20, 2026 - 15:03 UTC

Update

We have identified the cause of the login issue affecting some tenants and are currently validating a fix in our development environment to ensure it fully resolves the problem without introducing any further impact.

Once testing is successfully completed, we will deploy the update to the live environment and provide confirmation.

We appreciate your patience and will share a further update shortly.
Posted Feb 20, 2026 - 09:28 UTC

Identified

We are currently investigating an issue affecting the login process for the recruitment application, which is preventing some tenants from accessing the system.

Our team is actively working to identify the root cause and implement a resolution as quickly as possible.

This issue does NOT impact job search functionality. All job applications, CV submissions, and job board services remain fully operational.
Posted Feb 20, 2026 - 08:32 UTC
This incident affected: Recruitment.